Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Deepworld is back online after a system outage. Thanks for your patience.

Bug making mobs disappear.

2

Comments

  • TealHyenaTealHyena SmoresPosts: 715Member

    i like to complain @TealHyena

    Yes, indeed xD

  • SirentistSirentist Posts: 9,058Member, Moderator, Arbiter
    edited June 2017
    Androids AWOL again this morning. Could it be a time-related thing? Maybe I'm checking in too early...

    Edited to add:
    7:47 am: Android is back. Mysterious!
    Post edited by Sirentist on
  • RomyrjohnandreiRomyrjohnandrei I like to smell your hair while i watch you sleep in your bed from behind your closet....Posts: 1,337Member
    Androids are always missing
  • JackyJacky TownsvillePosts: 90Member
    It seems like the mobs are there, but we just cant see them.
  • TealHyenaTealHyena SmoresPosts: 715Member
    Jacky said:

    It seems like the mobs are there, but we just cant see them.

    That is the case. I've confirmed it.
  • TealHyenaTealHyena SmoresPosts: 715Member
    Okay. This is getting out of hand recently. It's nearly glitched all the time, in most worlds.
    @mikelaurence
  • Hydroblade29Hydroblade29 Posts: 1,818Member
    It's been over a month. EXP is hard to get nos.
  • InceptionInception Hello Darling Posts: 415Member
    I think I have a solution. I need to borrow everybody's onyx and then develop amnesia.....
  • RettaRetta Basking in so cal sunshinePosts: 553Member
    @TealHyena on artics you can see the worm tunnels but no worm :neutral:
  • mikelaurencemikelaurence New York CityPosts: 5,365Member, Administrator
    Trying some more server rollbacks soon, apologies. This bug sucks :(
  • TealHyenaTealHyena SmoresPosts: 715Member

    Trying some more server rollbacks soon, apologies. This bug sucks :(

    Agreed
  • MiesnerMan86MiesnerMan86 I Guess I’m backPosts: 600Member
    It seems some worlds get it more than others. Most unexplored public worlds get the bug less than private worlds. I have no idea what would cause this but thats what ive seen.
  • Shadow711Shadow711 I’m in a rather dark place, if you haven’t guessed by now.Posts: 882Member

    It seems some worlds get it more than others. Most unexplored public worlds get the bug less than private worlds. I have no idea what would cause this but thats what ive seen.

    My guess would be because the servers can't keep up with new worlds generating. The way worlds are (usually) generated in games are in layers.. an example would be blocks, generated structures, half blocks (guano, crystals, etc.), background, liquid, and THEN mobs. Of course mobs spawn when you're in the world and close to the spawnpoint, and that's why the server can't load them in.
  • MiesnerMan86MiesnerMan86 I Guess I’m backPosts: 600Member
    Shadow711 said:

    It seems some worlds get it more than others. Most unexplored public worlds get the bug less than private worlds. I have no idea what would cause this but thats what ive seen.

    My guess would be because the servers can't keep up with new worlds generating. The way worlds are (usually) generated in games are in layers.. an example would be blocks, generated structures, half blocks (guano, crystals, etc.), background, liquid, and THEN mobs. Of course mobs spawn when you're in the world and close to the spawnpoint, and that's why the server can't load them in.
    There may be some reasoning to this, i have noticed some invisible salt and guanno at times when i am filling in chunks of land with earth. It seems the game cannot handle that either? Dont know if this helps
  • Shadow711Shadow711 I’m in a rather dark place, if you haven’t guessed by now.Posts: 882Member

    Shadow711 said:

    It seems some worlds get it more than others. Most unexplored public worlds get the bug less than private worlds. I have no idea what would cause this but thats what ive seen.

    My guess would be because the servers can't keep up with new worlds generating. The way worlds are (usually) generated in games are in layers.. an example would be blocks, generated structures, half blocks (guano, crystals, etc.), background, liquid, and THEN mobs. Of course mobs spawn when you're in the world and close to the spawnpoint, and that's why the server can't load them in.
    There may be some reasoning to this, i have noticed some invisible salt and guanno at times when i am filling in chunks of land with earth. It seems the game cannot handle that either? Dont know if this helps
    It's possible that the liquid and half-blocks can be switched.. now that I realize no half-blocks really spawn under water, except stalagmites.
  • MiesnerMan86MiesnerMan86 I Guess I’m backPosts: 600Member
    Shadow711 said:

    Shadow711 said:

    It seems some worlds get it more than others. Most unexplored public worlds get the bug less than private worlds. I have no idea what would cause this but thats what ive seen.

    My guess would be because the servers can't keep up with new worlds generating. The way worlds are (usually) generated in games are in layers.. an example would be blocks, generated structures, half blocks (guano, crystals, etc.), background, liquid, and THEN mobs. Of course mobs spawn when you're in the world and close to the spawnpoint, and that's why the server can't load them in.
    There may be some reasoning to this, i have noticed some invisible salt and guanno at times when i am filling in chunks of land with earth. It seems the game cannot handle that either? Dont know if this helps
    It's possible that the liquid and half-blocks can be switched.. now that I realize no half-blocks really spawn under water, except stalagmites.
    what does liquid have to do with this? also i think terrapus eggs spawn underwater
  • AlphastormAlphastorm A higher plane of existence.Posts: 540Member

    Shadow711 said:

    Shadow711 said:

    It seems some worlds get it more than others. Most unexplored public worlds get the bug less than private worlds. I have no idea what would cause this but thats what ive seen.

    My guess would be because the servers can't keep up with new worlds generating. The way worlds are (usually) generated in games are in layers.. an example would be blocks, generated structures, half blocks (guano, crystals, etc.), background, liquid, and THEN mobs. Of course mobs spawn when you're in the world and close to the spawnpoint, and that's why the server can't load them in.
    There may be some reasoning to this, i have noticed some invisible salt and guanno at times when i am filling in chunks of land with earth. It seems the game cannot handle that either? Dont know if this helps
    It's possible that the liquid and half-blocks can be switched.. now that I realize no half-blocks really spawn under water, except stalagmites.
    what does liquid have to do with this? also i think terrapus eggs spawn underwater
    Terra eggs spawn underwater. I saw it several times in the process of making my worlds.
  • AlphastormAlphastorm A higher plane of existence.Posts: 540Member
    This glitch is a real headache @mikelaurence ,killing off my mob farms as it pleases. Kinda hard to have a mob farm with no mobs. :neutral:
  • MartragonMartragon Posts: 28Member
    I often get that bug, and sometimes I can't even farm, but recently I discovered it gets fixed when I go to alot of different worlds, I don't know if it works for everyone, but you should try it
  • AlphastormAlphastorm A higher plane of existence.Posts: 540Member
    Martragon said:

    I often get that bug, and sometimes I can't even farm, but recently I discovered it gets fixed when I go to alot of different worlds, I don't know if it works for everyone, but you should try it

    I did. Doesn't seem to last very long. That is, if it even comes back in the first place...
  • MartragonMartragon Posts: 28Member
    Well, it worked for me, and I still can see the mobs, I hope they don't dissapear again
  • MartragonMartragon Posts: 28Member

    Martragon said:

    I often get that bug, and sometimes I can't even farm, but recently I discovered it gets fixed when I go to alot of different worlds, I don't know if it works for everyone, but you should try it

    I did. Doesn't seem to last very long. That is, if it even comes back in the first place...
    Nevermind, you're right
  • Dr_DerpDr_Derp tejasPosts: 780Member

    Shadow711 said:

    It seems some worlds get it more than others. Most unexplored public worlds get the bug less than private worlds. I have no idea what would cause this but thats what ive seen.

    My guess would be because the servers can't keep up with new worlds generating. The way worlds are (usually) generated in games are in layers.. an example would be blocks, generated structures, half blocks (guano, crystals, etc.), background, liquid, and THEN mobs. Of course mobs spawn when you're in the world and close to the spawnpoint, and that's why the server can't load them in.
    There may be some reasoning to this, i have noticed some invisible salt and guanno at times when i am filling in chunks of land with earth. It seems the game cannot handle that either? Dont know if this helps
    The game used to have a lot more people, and more people means unexplored worlds get eaten up faster, and if the world generator could handle it back then, it definately can handle it today. I mean, it takes like 3 seconds between buying a private world and having it finish generating.

    The issue with invisible mobs is probably an error in transferring game state info from server to client properly, and my guess is that the new fossil mechanic may be linked to this.

    The invisible salt and guano issue could also be caused by or be causing this, but I remember issues with invisible fire salt going back to mid 2014 or so. And that just doesn't seem like it would cause problems with mobs.

    Now, I feel strongly on my theory of improper game state info because the invisible mobs still activate touchplates, which is handeled on servers.
  • MiesnerMan86MiesnerMan86 I Guess I’m backPosts: 600Member
    Dr_Derp said:

    Shadow711 said:

    It seems some worlds get it more than others. Most unexplored public worlds get the bug less than private worlds. I have no idea what would cause this but thats what ive seen.

    My guess would be because the servers can't keep up with new worlds generating. The way worlds are (usually) generated in games are in layers.. an example would be blocks, generated structures, half blocks (guano, crystals, etc.), background, liquid, and THEN mobs. Of course mobs spawn when you're in the world and close to the spawnpoint, and that's why the server can't load them in.
    There may be some reasoning to this, i have noticed some invisible salt and guanno at times when i am filling in chunks of land with earth. It seems the game cannot handle that either? Dont know if this helps
    The game used to have a lot more people, and more people means unexplored worlds get eaten up faster, and if the world generator could handle it back then, it definately can handle it today. I mean, it takes like 3 seconds between buying a private world and having it finish generating.

    The issue with invisible mobs is probably an error in transferring game state info from server to client properly, and my guess is that the new fossil mechanic may be linked to this.

    The invisible salt and guano issue could also be caused by or be causing this, but I remember issues with invisible fire salt going back to mid 2014 or so. And that just doesn't seem like it would cause problems with mobs.

    Now, I feel strongly on my theory of improper game state info because the invisible mobs still activate touchplates, which is handeled on servers.
    this is very true, although i still dont understand how invisible salt, a totally different object could cause this whole mess?
  • VengeVenge Not from Earth, I think...Posts: 440Member
    Is this issue fix, because I don't mind getting this fix at all. I mean, easy raid without brains you see... But I can't farm anymore this is a sad comeback.
  • mikelaurencemikelaurence New York CityPosts: 5,365Member, Administrator
    Trying a new server deploy as of late last night. Times Square still seems to be hosed, but other worlds... not? Let me know what you guys see.
  • AlphastormAlphastorm A higher plane of existence.Posts: 540Member

    Trying a new server deploy as of late last night. Times Square still seems to be hosed, but other worlds... not? Let me know what you guys see.

    Times had some mobs at some point in time @mikelaurence but I'm not sure if they are still there. Prognosis: Further research required.
  • MiesnerMan86MiesnerMan86 I Guess I’m backPosts: 600Member
    I have seen an increase of mobs, but not too much
  • stanicek3stanicek3 Gillingham KeepPosts: 391Member

    Trying a new server deploy as of late last night. Times Square still seems to be hosed, but other worlds... not? Let me know what you guys see.

    Mike you mad man I think you actually fixed it. Every world I've been to has been full of mobs.
  • SirentistSirentist Posts: 9,058Member, Moderator, Arbiter
    Two days in a row, Ethel has been in her beautiful house, waiting to be smacked! Hooray! O happy day!
Sign In or Register to comment.