Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Our latest update has been released! Please leave us a nice review in the App Store if you have the time, thank you!

Redownloading the game impossible

Mix2000qMix2000q Member Posts: 10
So i tried redownloading deepworld but it was just stuck like this, waited for over 30 minutes and nothing happened, can anyone help me with this? Im running ios 11.2 on an ipad air 1
22564BE1-B450-4B64-8F23-68A30B0FACEC.jpeg
226 x 219 - 56K

Comments

  • IronManArcherIronManArcher STEEEEEEEEEEAM JEETSMember Posts: 2,698
    Well, this isn’t a problem with Deepworld. Try deleting some other apps that you don’t use anymore.
  • Mix2000qMix2000q Member Posts: 10
    I have 3,5 gigabytes of free storage
  • GrebebeGrebebe 2Fab4UMember, Arbiter Posts: 1,006
    That's an iOS glitch that I've encountered many many times... never really found a solution other than wait and try another time
  • WhatsHisHeadWhatsHisHead // Deepgate //Member Posts: 162
    Try a forced reset of
    Your device maybe? Hold the power button till you see the force shut off button.
  • MultarixMultarix Over a rainbow with kittens and ponies dancing around a fire built upon the corpses of their enemiesMember Posts: 3,115
    It's likely to either be your internet connection or Apple having server issues (take your pick).

    Either restart your internet/ devices or wait a few hours and see if you're able to redownload then.

    This isn't something that Bytebin can really assist with unless there is some magical solution they're aware of that we are not...
    Give us your secrets mike.. hand them over
  • LilyabcLilyabc Kpop?Member Posts: 987
    It may just be your Ipad? I use to have an Ipad that had a lot of space but since it was old it couldn't download anything.
  • Mix2000qMix2000q Member Posts: 10
    i tried other apps, those downloaded fine, its just deepworld that does not want to download
  • GokuGoku On EarthMember Posts: 32
    Restart device, click on deepworld multiple times, hold icon try uninstall then reinstall. It will take a while but will be fine
Sign In or Register to comment.