Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

I keep getting "Execution Expired" when I try to log in.

Just downloaded the game on Steam a few minutes ago, made it through the tutorial, made an account with login and password, went to click the portal to leave the tutorial, and got booted. Then I tried to log in with the account info I had previously made, but when I input my login info, I get the spinning gear for a minute or so, then I get the "Execution Expired" message. Very frustrating since the game looked interesting and I was looking forward to playing.


  • SirentistSirentist Posts: 9,085Member, Moderator, Arbiter
    Did you get this worked out?

    I play on a Mac, so I can't help you directly, but I'll tag @Everywhen -- I think he plays on Steam. If not, he'll at least know who else to tag who might be able to help!

    (It may take him a bit to respond because he's on the opposite time zone from me, so he might not be online.)
Sign In or Register to comment.