Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

screenshot button causes crash

WalrusLordWalrusLord bbbbbbbbbPosts: 48Member
I don't know if this is known or not, but whenever I open the map and hit the screenshot button on the bottom right, after selecting a delivery method the game will just crash. I've tried restarting multiple times, too. I figured the button would be useful so I wouldn't have to screencap and crop. But kinda useless if it doesn't work.


  • IronManArcherIronManArcher STEEEEEEEEEEAM JEETSPosts: 2,886Member
    Same here. But that's been broken for a while.
  • tr4nsf0rmertr4nsf0rmer Posts: 210Member
    edited June 2018
    I think the crash log is same for everyone:
    “Exception Type: EXC_CRASH (SIGKILL)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
    Exception Note: EXC_CORPSE_NOTIFY
    Termination Reason: TCC, This app has crashed because it attempted to access privacy-sensitive data without a usage description. The app's Info.plist must contain an NSPhotoLibraryAddUsageDescription key with a string value explaining to the user how the app uses this data.
    Triggered by Thread: 1”
  • mikelaurencemikelaurence New York CityPosts: 5,367Member, Administrator
    Ah didn't know about this, I'll take a look, thanks.
  • CerealKillerCerealKiller On EarthPosts: 248Member
    It happened to me but only on my phone. I haven’t been on my old iPad for a while but it worked perfectly fine back then with it.
  • Bastian7Bastian7 Between WorldsPosts: 483Member
    I have a new iPad pro and same issue crashing when I try to screenshot. It’s why I haven’t posted any screenshots in a while.
  • IronManArcherIronManArcher STEEEEEEEEEEAM JEETSPosts: 2,886Member

    Ah didn't know about this, I'll take a look, thanks.

    Oh, whoops. I think it broke with either the space update or whatever patch or update was before that.
  • tr4nsf0rmertr4nsf0rmer Posts: 210Member
    edited June 2018
    It’s a very very easy fix tho. Just writing “NSPhotoLibraryAddUsageDescription“ instead of “NSPhotoLibraryUsageDescription” in the Info.plist.
    Works for my iPhone 6S now.image
Sign In or Register to comment.